PowerX logo
PowerX logo

All collections

PowerX Mobile App Requirements

We recommend that all users have the latest version of iOS or Android installed and updated on their devices to get the newest release and bug fixes for the PowerX mobile app. 

The PowerX mobile app is available for: iPhones and iPads running iOS 12.0 or later. Android 4.4W and up.

To connect your PowerX Hub to wifi, your iPhone must be running at least iOS 15. You may need to use a device running a newer version of iOS or Android first. 


Please note: The PowerX mobile app was designed and tested to work on the latest publicly released operating systems for iOS and Android. We cannot guarantee stability while using Beta or older versions of iOS or Android.

Was this article helpful?
Yes
No